Some account and event management pages are slow or non-responsive

Incident Report for Universe

Resolved

This incident has been resolved. All event management and account pages have been restored to full functionality.
Posted Feb 04, 2026 - 12:16 EST

Update

We have identified and restored impacted account pages. Investigation continues on the impacted event management pages.
Posted Feb 04, 2026 - 10:48 EST

Investigating

We are currently investigating this issue.
Posted Feb 04, 2026 - 09:50 EST
This incident affected: Event and Host Pages and Accounts and Authentication.