Host-Level Dashboard Data Latency
Incident Report for Universe
Resolved
This incident has been resolved.
Posted Aug 26, 2024 - 15:53 EDT
Investigating
We are investigating data latency on the dashboard. Please use the legacy dashboard in the meantime until the issue has been resolved: www.universe.com/dashboard/legacy
Posted Aug 21, 2024 - 20:11 EDT
This incident affected: Host Tools and Reporting (Host-level Dashboards).