Some Universe pages are slow to respond

Incident Report for Universe

Update

The root cause investigation is ongoing. In the interim, the Waitlisted count on the Event Overview dashboard will display 0 for all events. The Waitlist feature is completely functional with the exception of this display issue.
Posted Sep 12, 2025 - 10:57 EDT

Update

We have put a temporary fix in place to prevent further degraded performance. Investigation into the root cause is ongoing.
Posted Sep 12, 2025 - 09:33 EDT

Investigating

We are currently investigating this issue.
Posted Sep 12, 2025 - 09:00 EDT
This incident affects: Host Tools and Reporting (Dashboards).