Account-Level Dashboard Data Latency

Incident Report for Universe

Monitoring

Real-time data has been restored to the account dashboard. System performance is being monitored.
Posted Oct 24, 2025 - 08:58 EDT

Identified

We are investigating data latency on the dashboard. Please use the legacy dashboard in the meantime until the issue has been resolved: www.universe.com/dashboard/legacy
Posted Oct 22, 2025 - 09:37 EDT
This incident affects: Host Tools and Reporting (Dashboards).