Universe is currently experiencing issues related to a Google Cloud global outage

Incident Report for Universe

Resolved

Google has reported all services fully recovered as of 9:30PM ET (June 12).
Posted Jun 13, 2025 - 09:09 EDT

Identified

We are seeing intermittent issues as Google Cloud services are in the process of being restored.
Posted Jun 12, 2025 - 16:33 EDT

Investigating

We are actively monitoring the issue affecting Google Cloud services.
Posted Jun 12, 2025 - 15:08 EDT
This incident affected: Host Tools and Reporting (Dashboards, Downloadable Reports) and Checkout and Purchasing, Event and Host Pages, Accounts and Authentication.