Widgets Unable to Connect

Incident Report for Universe

Resolved

This incident has been resolved.
Posted May 20, 2025 - 07:12 EDT

Monitoring

We're monitoring the situation, but the systems have returned to normal.
Posted May 20, 2025 - 07:03 EDT

Update

Investigation is continuing, root cause appears to have been identified.
Posted May 20, 2025 - 06:53 EDT

Investigating

We are currently investigating this issue.
Posted May 20, 2025 - 06:00 EDT
This incident affected: Checkout and Purchasing and Widgets.