Degraded payment collection
Incident Report for Universe
Resolved
We have identified & resolved issues with email receipt deliverability this afternoon. We're continuing to monitor for signs of degraded delivery performance. A post-mortem will follow once our investigation concludes.
Posted Aug 25, 2022 - 19:26 EDT
Investigating
we're currently seeing degraded performance in our payment collection system - we're monitoring to ensure all transactions are processed as quickly as possible
Posted Aug 25, 2022 - 15:47 EDT
This incident affected: Ticket Processing Queue.