Payment provider service interruption
Incident Report for Universe
Resolved
Stripe has posted that these issues have been resolved.
Posted Jun 12, 2020 - 19:59 EDT
Investigating
Our payment provider Stripe is currently experiencing elevated error rates and response times. This may affect payment processing and refunds.

https://twitter.com/stripestatus/status/1271586092752367618?s=20
Posted Jun 12, 2020 - 19:40 EDT
This incident affected: Ticket Processing Queue.