Elevated Card Declines
Incident Report for Universe
Resolved
This incident has been resolved.
Posted 12 months ago. Jun 07, 2018 - 20:55 EDT
Update
Stripe is reporting their outage has been resolved, Universe has resumed queue in flow and all buyers will be processed shortly.
Posted 12 months ago. Jun 07, 2018 - 20:55 EDT
Update
We are again seeing intermittent card declines - we have paused our checkout queue in order to preserve sales, and to prevent ticket buyers from observing errors.
Posted 12 months ago. Jun 07, 2018 - 20:42 EDT
Update
Stripe has acknowledged the service outage, more details will be available at: https://status.stripe.com

Universe is observing successful payment processing at this time.
Posted 12 months ago. Jun 07, 2018 - 20:36 EDT
Investigating
We are observing intermittent service outage from our upstream payments provider Stripe. We will update with more details shortly.
Posted 12 months ago. Jun 07, 2018 - 20:31 EDT
This incident affected: Ticket Processing Queue.