Reporting Latency
Incident Report for Universe
Resolved
This issue has been remediated.
Posted 11 months ago. Aug 13, 2018 - 15:09 EDT
Monitoring
Issue will be resolved shortly. We have implemented a fix.
Posted 11 months ago. Aug 13, 2018 - 10:22 EDT
Identified
We are observing reporting latency.
Posted 11 months ago. Aug 13, 2018 - 09:58 EDT