Overview reports under the manage panel are partially showing incorrect data.
Incident Report for Universe
Resolved
A recent released caused this issue. The release has been reverted. All reports are back to normal now.
Posted 11 months ago. Aug 13, 2018 - 12:58 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. Aug 13, 2018 - 12:23 EDT