Homepage
Incident Report for Universe
Resolved
This incident has been resolved.
Posted 3 months ago. May 24, 2019 - 09:34 EDT
Monitoring
The Universe.com homepage is currently in maintenance mode. This maintenance period will last until 9AM EST. All other site functions, ticket sales, event pages, event creation functionalities remain online.
Posted 3 months ago. May 24, 2019 - 03:03 EDT