Payment Processing Issue
Incident Report for Universe
Resolved
Stripe has fixed the issue and functionality to our platform is restored.
Posted about 2 months ago. Jul 10, 2019 - 17:44 EDT
Investigating
There is a service degradation with our payment processor Stripe. We are monitoring the situation.
Posted about 2 months ago. Jul 10, 2019 - 17:18 EDT