Reporting Latency Degraded
Incident Report for Universe
Resolved
The issue has been resolved and all reports should be up to date
Posted 12 months ago. Aug 01, 2018 - 16:20 EDT
Investigating
Reports may not reflect the latest data at this time. We are investigating and should have a fix shortly
Posted 12 months ago. Aug 01, 2018 - 14:52 EDT